Meine Werkzeuge

Release Historie - Goliath 5.5 (powered by k-advice)

Aus k-advice WIKI

Wechseln zu: Navigation, Suche

Version 5.5.006.x (Termin noch offen)

Neuentwicklung

Goliath
Auftragsrückstände - Performance/Spaltenanpassung/Anhaken nach Liefertermin bzw. Reservierungsdatum
In den Auftragsrückständen unter Auftrags-Center -> Auftragsverwaltung -> Verfügbarer Funktionsbaum -> Aufträge -> "Auftragsrückstände" wurde die Geschwindigkeit der Abfrage ordentlich beschleunigt.
Was früher in großen Datenbanken 11:30 Min dauerte, ist jetzt in 30 Sek. fertig. :-)
Die Spalte "Vorauszahlung" wurde entfernt und durch die Spalte "Versandart" (des Auftrag) ersetzt. Somit ist jetzt direkt ersichtlich, welche Waren bspw. abgeholt oder versendet werden müssen.
Der Doppelklick zur Markierung als "bezahlt" wurde entfernt.
Sollten mehrere Aufträge mit gleichem Artikel in den Auftragsrückständen erscheinen und der Verkaufsbestand nicht für alle Aufträge ausreichend sein, so wird nun nach dem Liefertermin der Auftragsposition aufsteigend angehakt. Somit wird vorgeschlagen, den Auftrag mit dem kleinsten Datum als Liefertermin auszuliefern. Ist im System die Funktion der automatischen Reservierung aktiviert, hat das Reservierungsdatum eine noch höhere Priorität zum Liefertermin. Somit wird automatisch nach dem kleinsten Reservierungsdatum aufsteigend angehakt.
Die Sortierung der Einträge wurde auf Kunde/Projekt/Liefertermin angepasst.
Wareneingang ohne Rechnung
Im Wareneingang wurde die Auswertung "Wareneingang ohne Rechnung" angepasst, dass jetzt WAE von RMA-Lieferungen ausgeschlossen werden können.
In der Ansicht kann jetzt auch mit Strg + S gesucht werden, außerdem kann man jetzt mit +/- alles auf-/zuklappen.
Auftrags-Historie - Performance/Optimierte Darstellung/Filter Kfm. Betreuer
In der Funktion unter Auftrags-Center -> Auftragsverwaltung -> Verfügbarer Funktionsbaum -> Aufträge -> Auftrags-Historie bzw. der Button mit dem roten Buch im Kunden-/Artikelstamm, wurde die Performance der Abfrage ordentlich beschleunigt. Ebenso wurde eine neue Filteroption integriert, welche jetzt zusätzlich nach dem kaufmännischen Betreuer des Projektes filtern lässt. Die Darstellung der Zahlen wurde verbessert, es wurden 1000er-Trennzeichen eingefügt. Beim Klick auf den "rote Buch"-Button läuft die Auswertung jetzt nicht mehr automatisch los, um vorher die gewünschten Filterparameter einstellen zu können. Die Filterparameter der rechten Seite in der Maske, sowie die "DB-Einstellung", "Interne Kunden ausschließen" als auch "Stücklisten berücksichtigen" wird beim Verlassen der Maske am Client gespeichert und beim nächsten Öffnen der Auswertung wieder geladen.
Serviceverwaltung - Benutzerfelder für Vertrag
Sowohl bei den EDV- als auch Copy&More-Verträgen ist ein neuer TAB im Vertrag vorhanden, welcher das Pflegen von Benutzerfeldern auf den Vertrag ermöglicht. Die Benutzerfelder hängen am Vertragskopf und nicht an den Vertragspositionen.
Standard E-Mail Empfänger für Angebote, Auftragsbestätigungen, Mahnungen und Bestellungen
Bei den Ansprechpartnern kann nun für Kundenansprechpartner eingestellt werden, dass ein oder mehrere Ansprechpartner die Standard-Empfänger per E-Mail für die o.g. Vorgänge sind. Ist bspw. bei einem Kunden ein Ansprechpartner als Standard-Empfänger per E-Mail für Angebote angehakt, so wird nur dieser beim Versenden des Angebot per E-Mail in der Liste der Ansprechpartner vorselektiert. Ist kein Standard-Empfänger gewählt, so wird wie bisher der im Kopf gewählt Ansprechpartner vorausgewählt.

Verbesserungen

Goliath
Verzeichnisstruktur für Dokumente
Erweitern der Verzeichnisstruktur für Dokumente bis zum Jahr 2030
Auftragsrückstände - Filter kfm. Betreuer
Wurde auf einen kfm. Betreuer gefiltert und der Filter anschließend auf "Alle" zurückgesetzt, blieb die Liste leer. Jetzt werden wieder alle Aufträge geladen.
OP-Debitoren -> Bebuchte Konten -> Drucken der Einzelbuchungen je Konto
Es wurde nun ein Report eingefügt, um die Liste der Buchungen im Querformat ausdrucken zu können.
Baum-Ansichten (TreeViews) - Verbesserung in Navigation
In allen Datengrids, welche als Baum-Ansicht angezeigt werden, kann jetzt der einzelne Knotenpunkt mit der Pfeiltaste LINKS/RECHTS auf- und zugeklappt werden. Diese Funktion steht überall dort zusätzlich zur Verfügung, wo bisher bereits alle Knotenpunkte mit PLUS/MINUS auf- und zugeklappt werden konnten.
Warengruppen anlegen - Merkmal "DB nicht berechnen"
Der Standard-Wert von "Deckungsbeitrag nicht berechnen" wurde von True auf False geändert. Das Problem in der Vergangenheit war, dass oft vergessen wurde den Haken zu entfernen und somit alle Artikel, welche in dieser Warengruppe angelegt wurden, nicht in die Umsatz- und Deckungsbeitragsauswertungen aufgenommen wurden. Somit waren die Werte in den Statistiken i.d.R. immer zu gering.
Ändern der Datentypen in der Datenbank
Diese Änderungen führen zu einer schnelleren Verarbeitung der Datenabfragen / Datenaktualisierung und spart Platz in den Tabellen was die maximal möglichen Einträge erhöht.
Nummerische Datenbankfelder größer 3 und kleiner 10 ohne Nachkommastellen sind jetzt Typ: INTEGER
Nummerische Datenbankfelder größer 9 und ohne Nachkommastellen sind jetzt Typ: DOUBLE
Nummerische Datenbankfelder größer 7 und mit Nachkommastellen sind jetzt Typ: DOUBLE
ZDE Bearbeiten / Mitarbeiter Auswahlbox
Der Index der Auswahlbox steht jetzt auf 1 und nicht mehr auf dem angemeldeten Benutzer.
Gutschrift aus Rechnung erstellen
Es muss jetzt per Auswahl definiert werden ob nach der Projekt- oder Rechnungsnummer gesucht werden soll. Bisher konnte es ohne genaue Auswahl dazu führen, dass bei Überschneidungen der Nummernkreise zwischen Projekt- und Rechnungsnummer der falsche Vorgang gefunden wurde.
Löschen von Ansprechpartnern, Stammdaten- oder Ansprechpartner-Mailadressen
Sofern ein Ansprechpartner als Empfänger von E-Mailrechnung ausgewählt wurde, wird nun ein löschen verhindert. Ebenso kann die Mailadresse aus dem Ansprechpartner nicht gelöscht werden. Dasselbe gilt für E-Mailadressen in den Kundenstammdaten.
Log-Dateien in Goliath-Clientverzeichnis
Sofern in den Lokalen Einstellungen "Lokale DB reindizieren" aktiviert war, wurde beim jedem Start der Anwendung eine Log Datei in den Client nach ...\Database\Reindexlog geschrieben. Dieses Log wurde nun deaktiviert. Bestehende Logs können bei Bedarf selbst gelöscht werden.
Zähllisten drucken bei Inventur
Bisher wurde der Pfad zu den individuellen Zähllisten-Dateien als "harter" Pfad abgespeichert. Somit konnte es vorkommen, dass beim Versuch eine Zählliste an einem anderen Arbeitsplatz auszudrucken, an welchem bspw. das Netzlaufwerk einen anderen Buchstaben hatte, fehlschlug. Jetzt wird ein relativer Pfad verwendet und stellt das Auffinden der Zähllisten-Dateien sichern.
Mengenänderung bei mehreren Auftragspositionen in Abbuchen-Maske der Auftragsverwaltung
Wurde in der Maske des Abbuchen/Splitten in der Auftragsverwaltung bei mehreren Auftragspositionen die Abbuchungsmengen geändert, so wurde bisher trotzdem nur beim markierten Artikel die neue Menge abgebucht. Jetzt werden alle Mengenänderungen in der Maske berücksichtigt.
Artikelstamm - Artikel kopieren
Die letzte Auswahl (checked/unchecked) der Option "Artikel-Benutzerfelder kopieren" wird jetzt gespeichert.
Auftrags-Center -> Statistiken - Kunden-Artikel Statistik und Auftrags-Historie
Diese Einträge wurden aus den Statistiken entfernt, da diese bereits im Kunden- und Artikelstamm über den Buttonen mit dem Icon (rotes Buch) bereitstehen, sowie unter Auftragsverwaltung -> Verfügbare Funktionen -> Aufträge -> Auftrags-Historie.
Reindex
Verkleinern des Datenvolumen von Log-Dateien
Die Tabelle _outlscan_log wird nun bei jedem Reindex geleert, um Festplattenplatz zu sparen.
Es werden jetzt nur noch die Reindex- und Captionlogs für ein halbes Jahre archiviert.

Fehlerkorrekturen

Goliath
Auftragsverwaltung -> Kunden-Umsatz Informationen (Button neben Anzeigefilter mit grünem Dollar-Symbol)
Es konnte vorkommen, dass nicht alle Umsatzjahre des Kunden in der Auswahlliste angezeigt wurden.
Reservierungen - Lager-Center -> Reservierungen
Wurde eine Reservierung in der Toolbar gelöscht, so blieb der Reservierungshaken in der Auftragsposition erhalten. Jetzt wird auch dieser entfernt.
Die Liste der Reservierungen kann jetzt mit "Strg+S" in Volltext durchsucht werden. Mit + und - kann der gesamte Baum jetzt auf-/zugeklappt werden.
Reservierungen - Auftragsverwaltung
Die Funktionen Projekt-Umbuchen -> "Projekt zu anderem Kunden" / -> "Position zu anderem Kunde" ziehen jetzt auch die Reservierung mit auf den neuen Kunden und das neuen Projekt um.
Die Funktion "Angebote verschieben" bietet auch die Funktion eine neue Auftragsposition zu erzeugen. Beim erzeugen der Auftragsposition wird jetzt auch das Reservierungsmerkmal gesetzt und die Reservierung angelegt.
Wird die Abbuchung einer ursprünglich reservierten Auftragsposition rückgängig gemacht, so wird die ursprüngliche Reservierung mit den alten Reservierungsdaten wiederhergestellt. Wurde in der Zwischenzeit ein Reindex auf der Tabelle ausgeführt, so wird eine neue Reservierung mit aktuellem Tagesdatum angelegt.
Bearbeitungshistorie - Edit-User /-Datum /-Uhrzeit
Die Inhalte dieser drei Felder, werden jetzt nicht mehr in die Bearbeitungshistorie aufgenommen.
Serien-Nr. Suche / Finde Seriennummern
In Datenbanken, welche noch keine Serien-Nr. beinhalten ist die Maske der Serien-Nr. Suche in ein Deadlock (Endlosschleife) gelaufen.
Splitten der Auftragsposition bei aktivierter Kupferlizenz
Bei aktivierter Kupferlizenz wurde, bei allen Positionen des gleichen Artikel, im Abbuchendialog die Mengen überschrieben.
Zählerstandsimport in Serviceverwaltung
Bei der Spaltenzuordnung zu den jeweiligen Zählern konnte es vorkommen, dass die Zuordnung im Hintergrund zwar gesetzt wurde, die Anzeige für den Anwender allerdings nicht aktualisiert wurde. Dies ist nun sichergestellt.
Anlegen von Benutzern
Es kam zu einer Fehlermeldung, wenn der Benutzer am Ende einen Punkt hatte. Dies ist nun möglich.
Wurde ein Benutzer im "gefilterten Modus" (Auswahl über Combobox in Benutzerliste) editiert, so konnte es vorkommen, dass nicht der aktuelle Benutzer, sondern der vorherige Benutzer in den Einstellungen verändert wurde. Nun ist die Fokusierung auf den gewählten Benutzer sichergestellt.
Der Haken zur Berechtigung auf den jeweiligen Mandanten wurde beim Anlegen oder Kopieren von Benutzern nicht immer automatisch aktiviert. Ein nachträgliches setzen führte erst nach mehreren Versuchen zum Erfolg. Beides ist nun in der Funktion sichergestellt.
Taskloader
Ausführungsprotokollierung
Die Protokollierung jeder Ausführung per Timestamp in ein Memo-Feld wurde deaktiviert. In der Vergangenheit konnte es dazu führen, dass ein Task nicht mehr ausgeführt wurde, weil die Größe der Log-Datei größer 2GB wurde.

Version 5.5.005.A vom 18.02.2019

Neuentwicklung

Goliath
Rechnungsnummer und Fibu-Belegnummer hat nun 36 Zeichen
Seit Version 7.1 DATEV-Rechnungswesen-Programme (August 2018) ist das Belegfeld 1 in Datev auf 36 Zeichen erweitert worden. Somit wurde dies auch in Goliath 5.5 angeglichen.
Übergabe an Datev jetzt in Version 700 und Formatversion 9
Belegfeld 1 jetzt 36 Zeichen, Buchungstext 60 Zeichen, neue Spalten [Fälligkeit, Generalumkehr, Steuersatz, Land]
ACHTUNG! Ist Datev noch nicht auf Version 7.1 DATEV-Rechnungswesen (DATEV-Programme 12.0) aktualisiert, müssen Sie in den Globalen Einstellungen -> OP-Einstellungen -> Fibu-Schnittstelle das Format auf "Datev Format v510 Fv07 (EXTF)" zurückstellen. Dies führt allerdings dazu, dass nur 12 Zeichen im Belegfeld 1 übergeben werden.
Bestellmahnungen / Lieferanmahnungen
Die bisherigen Bestellmahnungen wurden durch ein neues lizenzpflichtiges Modul ersetzt.
Jetzt können Bestellmahnungen optimiert Abgefragt und mit offenen Kunden-Aufträgen und dessen Lieferterminen gegenübergestellt werden. Somit lässt sich bspw. Filtern, welche Bestellpositionen überfällig sind, jedoch Kunden-Auftragspositionen in den nächsten 14 Tagen ausgeliefert werden müssen. Bei Interesse kontaktieren Sie bitte unseren Support.
Artikel-Disposition (in Dispo-Variante 2) [Weinroter Kreis mit weißem Fragezeichen]
Aufnehmen der Spalten:
  • Mahnstufe = Aktuelle Bestellmahnstufe
  • Mahndatum = Letztes Bestellmahndatum
Lieferanten-Ansprechpartner
Es kann nun beim Ansprechpartner hinterlegt werden ob dieser der Standardempfänger für Bestellmahnungen ist.
Allgemeine Daten -> Bestellungen -> Mahnungen
Es kann nun das Standard E-Mail-Template je Mahnstufe hinterlegt werden, sowie die Option des automatischen Versenden der E-Mail.
Runtime-Files VFP9 und ActiveX-Files für zukünftige Versionen
Beim Starten von Goliath wird geprüft ob die notwendigen Runtime- und ActiveX-Files existieren. Sofern diese nicht vorhanden sind, bekommt der Anwender eine Meldung, dass für zukünftige Versionen (ab 5.5.006.x) diese Dateien installiert werden müssen. Goliath muss somit an jedem Arbeitsplatz einmalig mit "Als Administrator ausführen" gestartet werden.
Alternativ können die folgenden MSI für eine Softwareverteilung via Gruppenrichtlinien verwendet werden:
http://goliath.k-advice.de/install/setup_ka_vfp9rt_v1.3.0.msi
http://goliath.k-advice.de/install/setup_ka_codejock_v18.6.2.msi
OP-Debitoren/Kreditoren -> Bearbeiten/Ändern des OP
Neuer Button mit dem Namen je geschalteter Lizenz "Speichern + OCR-Label drucken" bzw. "Speichern + Dokument scannen"
Diese Funktion ermöglicht eine schnellere Abarbeitung der Dokumentenzuordnung zum offenen Posten.
Kundenbetreuer in Stammdaten (Kunden, Kunden-Standardeinstellungen, Interessenten)
Als Werte zur Auswahl stehen nun die Benutzer und nicht mehr die Mitarbeiter-Kurzbezeichnung zur Verfügung. Die bestehenden Werte werden durch das Update automatisch auf den Benutzer konvertiert.
Auftragsverwaltung Projektkopfdaten (Projekt-Parameter) Feld kaufmännischer Betreuer
Der Standardwert der Combobox kann nun auf den Kundenbetreuer des Kundenstamm gesetzt werden. Dies macht Sinn, wenn bspw. mit festen Key-Accounts gearbeitet wird und die Umsätze auf den Key-Account laufen sollen, selbst wenn die Assistenz die Projekte anlegt. Hierfür den folgenden Haken setzen: Globalen Einstellungen -> Auftragsverwaltungseinstellungen -> TAB Allgemeine Parameter -> Kfm. Betreuer bei Projekt-Neuanlage mit Kundenbetreuer aus Kundenstamm vorbelegen
Auftragsverwaltung Projektkopfdaten (Projekt-Parameter) Feld technischer Betreuer
Früher wurde der technische Betreuer bei Projektneuanlage auf den Kundenbetreuer des Kundenstamm gesetzt. Diese Funktion existiert nun nicht mehr. Die Combobox wird immer per Standard auf den angemeldeten Benutzer gesetzt.
Auftragsverwaltung / Bestellwesen / Wareneingang
Im Fußbereich der Maske wird nun zusätzlich zum Netto- und Bruttowert die Mehrwertsteuer im Feld Mwst. ausgewiesen.
Service-Verwaltung - Neue Filter in Abrechnung EDV-Verträge
Es kann nun in der Maske gefiltert werden, dass nur Rechnungen mit einem Rechnungsbetrag > 0 angezeigt werden. Ebenso kann auf den Vertragstypen gefiltert werden, um eine differenzierte Abrechnung unterschiedlicher Vertragskategorien innerhalb einer Abrechnungsperiode durchführen zu können.
Service-Verwaltung - Neue Filter in Abgerechnete Verträge
Erweitern der Filterfunktion um "Nur Rechnungsbetrag > 0", sowie die Möglichkeit auf den Vertragstypen filtern zu können. Das Filtern des Rechnungsbetrag > 0 ist in Kombination mit dem Rechnungsversand per E-Mail sehr hilfreich, um sicherzustellen, dass keine 999999999-Rechnungen mit einem 0 EUR Betrag versendet werden.
Service-Verwaltung - Neue Filter in Vertragsabrechnung
Es kann nun für die Abrechnung nach dem Vertragstypen gefiltert werden, um innerhalb einer Abrechnungsperiode unterschiedliche Vertragskategorien abrechnen zu können.
Service-Verwaltung - Abrechnung EDV-Verträge, jetzt direktes Bearbeiten des Tätigkeitstext
In der Liste der Mehrverbrauchsabrechnungen wurde bisher jede Arbeitszeit mit der zugehörigen Techniker-Auftragsnr. angezeigt, über welche man mit Doppelklick zum Techniker-Auftrag springen kann. Dieses Fenster wurde gesplittet, so dass nun auch der Tätigkeitstext angezeigt und direkt editiert werden kann. Dies ist für die Abrechnung sehr hilfreich, um unqualifizierte Texte oder Vertipper schnell und einfach korrigieren zu können.
Datumsüberprüfung - Warnung bei Datumseingabe +- 120 Tage
Sofern in den Einstellungen -> Globalen Einstellungen -> Datumsüberprüfung noch kein Wert für kleiner oder größer aktuelles Datum eingetragen ist, so wird der Wert "120 Tage" eingetragen. Somit erhält der Anwender eine Warnmeldung, wenn ein Datum, welches kleiner oder größe 120 Tage ist, eingetragen wird. Somit werden Vertipper in der Jahreszahl wie bspw. 2190 statt 2019 vermieden.

Verbesserungen

AZV-Komplett
Liste bzw. TAB offene Aufgaben
Vorher wurde der Datensatzzeiger nicht nach oben sortiert und der Fokus stand in der Mitte der Liste. Jetzt wird die Anzeige nach oben gesetzt und man befindet sich auf dem ersten Datensatz.
Inkrementelle Suche
Bisher mussten mindestens 3 Zeichen für die Suche eingegeben werden, selbst wenn bereits beim ersten Zeichen der gesuchte Vorschlag angezeigt wurde. Jetzt wird direkt beim Verlassen des Feldes die Suche ausgeführt, unabhängig von der Anzahl eingegebener Zeichen.
Goliath
Bestellwesen
Im Bestellwesen ist jetzt sowohl für die Bestellpositionen als auch für den Bestellkopf das Gewicht im Anzeigegrid verfügbar.
Suchmaske in Bestellwesen, Wareneingang, OP-Debitoren, OP-Kreditoren, Service-Verwaltung, Techniker-Center
ENTER führt jetzt zum Ausführen der Suche, früher wurde nur das Suchfeld verlassen.
XFRX Version 18.1.5 (Druck- und PDF-Engine)
Besserer Support beim Exportieren der Reports nach Word.
Beheben des Problem, dass bei Werbetexten über mehrere Seiten ein Teil des Textes abgeschnitten wurde. Dies passierte bspw. bei großen Zählerabrechnungen eines Copy & More-Vertrag.
Es kann jetzt im Root des Goliath-Client eine XFRXDebug.ini angelegt werden, um von der Engine eine Rückmeldung über mögliche Fehler im Report zu erhalten. Das Log wird fortlaufend in die Datei xfrx.log geschrieben.
E-Mailauswahlliste bei Versand per E-Mail
Die Liste der E-Mailadressen ist jetzt nach "Name, Vorname" sortiert. Sofern im Kopf des Vorgang (bspw. Angebotskopf) bereits der Ansprechpartner ausgewählt wurde, so wird dieser jetzt auch eindeutig identifiziert und vorausgewählt. Früher konnte es passieren, dass bei einem ausgewählten Ansprechpartner "Rau" alle E-Mailadressen mit der Anrede "Frau" ausgewählt wurden.
Stücklisten Tabellen der Bewegungsdaten (stk_ag und stk_ab)
Einführen/Konvertierung der Datentypen auf Integer und Double. Reduzierung der Dateigröße der .DBF, um 1/3 der bisherigen Größe.
Neue Messagebox
Refactoring der bisherigen Meldungen/Messageboxen, um Probleme bei der Anwendungsverriegelung zu beheben. Es konnte vorkommen, dass die Anwendung nicht beendet werden konnte, weil diese in einem Messagebox-Dialog stand.
Aktualisierung des Client
Bisher bekam man, bei eingeschaltetem Socket-Server in Goliath, nach der Aktualisierung des Client eine Meldung, dass der konfigurierte Port bereits belegt ist. Jetzt wird vor dem Start der Aktualisierung der Port freigegeben und der Socket-Server beendet. Beim Neustart von Goliath ist der Port somit frei und es erscheint keine Meldung mehr.
Fibu-Schnittstellen
Entfernen der Einträge FiBuNet, Oracle Financials, Sage KHK, Fibu Offline, Fibu Online, GDILine, CSV-Datei. Diese Schnittstellen werden nicht mehr unterstützt.
OP-Debitoren/Kreditoren -> Rechtsklick auf OP -> Dokument Scannen
Je Lizenz wird im Menü jetzt "Dokument scannen" oder "OCR-Label drucken" angezeigt.
Bei "OCR-Label drucken" wird der Drucker nun nach dem Druckvorgang auf den vorherigen Drucker zurückgesetzt.
Entfernen inaktiver Benutzer/Mitarbeiter aus Comboboxen
Im gesamten Programm wurden die Benutzer/Mitarbeiterlisten angepasst. Nun werden die inaktiven Benutzer ans Ende der Comboboxen sortiert und für neue Datensätze können diese nicht mehr ausgewählt werden. Im Login existieren nur noch aktive Benutzer. Für die Anwesenheitszeiten (ZDE bearbeiten) sind die inaktiven Benutzer dennoch für Auswertungszecke auswählbar und werden mit dem Merkmal "inaktiv" gekennzeichnet. Ein Benutzer ist inaktiv, wenn das Austrittsdatum im Mitarbeiterstamm befüllt ist oder der Mitarbeiter einen Haken bei der Eigenschaft inaktiv hat.
Sonderzeiten in ZDE-Center - ZDE bearbeiten
Früher konnte bei manueller Eingabe des Vortrag für Überstunden und Urlaub nicht direkt gespeichert werden. Erst nach dem Hinzufügen einer Sonderzeit wie bspw. Urlaub oder Berufsschule wurde der Speichern-Button aktiv. Jetzt wird direkt bei manueller Eingabe der Vorträge der Speichern-Button aktiv.
Excelexport aus Statistiken und Übersichten
Nachstehende Leerzeichen wurden beim Export entfernt. Beschleunigen des Export. Abfangen mit OLE-Fehlermeldungen, wenn das erste Zeichen ein Gleichheitszeichen war. Beim Export von Datumsvertippern wie bspw. 0201 anstatt 2001, konnte es zu einem Fehler kommen, weil das kleinste mögliche Jahr bei Excel 1900 ist.
Abrechnungstext der Vertragsabrechnung für Copy & More Verträge
Die Lesbarkeit der Abrechnung wurde verbessert. Bei den Verbrauchseinheiten und Beträgen wurden 1000er-Trennzeichen eingefügt. Die Gesamtbeträge am Ende je Zählergruppe wurden von den einzelnen Vertragspositionen abgesetzt. Artikelbez. ist jetzt Bezeichnung, doppelter Doppelpunkt beim Standort in der Zählerabrechnung wurde entfernt, ein falscher Einzug in der Zusammenfassung wurde entfernt. Zwischen jeder Vertragsposition ist auf der Rechnung nun eine Leerzeile.
Abrechnungstext der Vertragsabrechnung für EDV-Verträge
Die Lesbarkeit der Abrechnung wurde verbessert. Bei den Verbrauchseinheiten und Beträgen wurden 1000er-Trennzeichen eingefügt.
Auftragsverwaltung -> Kunden-Umsatz Informationen (Button neben Anzeigefilter mit grünem Dollar-Symbol)
Die Art der Datenabfrage wurde verändert, dass nun für Angebot, Auftrag, Rechnung und Gutschrift nicht mehr nach dem Projekt-Erstelldatum ausgewertet wird. Die Abfrage wurde den regulären Statistiken in Goliath 5.5 angeglichen, so dass Angebot und Aufträge nach dem Erstelldatum der jeweiligen Kopfdaten abgefragt werden / Rechnung und Gutschrift nach dem Erstdruckdatum der Positionen. Die Werte besitzen nun auch das 1000er-Trennzeichen.
Bestellen über die Auftragsverwaltung
Es werden jetzt nur noch nicht abgebuchte Auftragspositionen berücksichtigt, welche eine bisherige Bestellmenge kleiner der Auftragsmenge der jeweiligen Auftragsposition haben.
Reindex
Freigabe für UNC-Pfad
Der Reindex unterstützt nun auch einen UNC-Pfad mit großer Anzahl an Zeichen.

Fehlerkorrekturen

AZV-Komplett
Inkrementelle Suche
Hatte ein Kunde eine Kurzbezeichnung mit mehr als 46 Zeichen, blieb die Suche ergebnislos mit der Meldung "Keine Daten gefunden".
Goliath
Online-Order TechData funktioniert nun wieder
Es wird jetzt das aktuelle Schema XMLGATE Version 4.04 geliefert.
Wenn Sie diese Funktion nutzen möchten, so fragen Sie bei unserem Support nach. Es müssen hierfür einige Inhalte in der Konfig.-Tabelle ausgetauscht werden.
Inventur - Zählliste löschen
Wurde beim Löschen einer Zähllisten die Frage "Zählliste <Zähllistenname> wirklich löschen?" mit "Ja" anstatt mit "Ja für Alle" beantwortet, so wurden trotzdem alle Zähllisten gelöscht. Jetzt wird wie geplant nur die markierte Zählliste gelöscht.
Druck- und PDF-Engine
In der Vergangenheit konnte es in seltenen Fällen dazu kommen, dass ein Vorgang (Angebot, Auftragsbestätigung, etc.) mehrfach die Position 1 enthalten hatte, alle anderen Positionen fehlten. Es wurde die Datenaufbereitung optimiert was diesen Fehler nun beheben sollte.
Maske der Ansprechpartner
Bisher konnte die Feldbezeichnung der Ansprechpartner-Maske nur für alle Module (Kunden, Lieferanten, Interessenten, Vertreter) angepasst werden. Jetzt ist eine individuelle Bezeichnung der Feld-Captions je Modul möglich.
Rechnungsstatus ändern mit zeitlicher Beschränkung
Es konnte vorkommen, dass bei überschneidenden Nummernkreisen zwischen Rechnung und Gutschrift der falsche Beleg auf das Rücksetzungsdatum geprüft wurde.
Rechnungsstatus ändern wenn Abschlagsrechnungen im Projekt vorhanden
Wurde die Funktion "RE-Status ändern" bei einer Rechnung angewendet und es existierten Abschlagsrechnungen im Projekt, so versuchte Goliath immer die erste Abschlagsrechnung zurückzusetzen, anstatt die eigentlich ausgewählte Schlussrechnung.
Rechnungsstatus ändern
Bisher wurde auch der Lieferschein-Druckhaken in der Projektübersicht entfernt, wenn eine Rechnung zurückgesetzt wurde. Jetzt bleibt dieser unberührt.
Chef Frühwarn-Center
Bei Überschneidungen zwischen den Projekt- und Wareneingangsnummern, wurden unter "Unstimmigkeiten Auftragsverwaltung-Offene Posten" falsche Einträge angezeigt, weil die Rechnungsbeträge der Auftragsverwaltung mit den Rechnungsbeträgen eines Wareneingang gegenübergestellt wurden.
Benutzer-Rechte - Filter-Funktion auf Benutzer
Bisher wurde beim Filtern auf den Benutzer MUELLERA auch die Benutzer MUELLERB oder MUELLERX angezeigt. Nun werden nicht nur die ersten Zeichen geprüft, sondern der gesamte String.
Offlinestatistik - Modul OP-Kreditoren
Beim Klick auf die Offlinestatistik wurden keine Daten angezeigt. Jetzt wird die korrekte Maske geladen.
Projektkalkulation über Rechtsklick auf Angebots- /Auftragsposition - Button <Preise abfragen>
Es konnte zu einer Fehlermeldung "SQL: Spalte "LFID2" wurde nicht gefunden." kommen. Dieser Fehler ist nun behoben.
Finanz-Center -> Fibu-Übergabe
Bei ausgewählter Systemeinstellung Globale Einstellungen -> OP-Einstellungen -> Fibu-Schnittstelle Wert: "Datev" (altes KNE/Postversand-Format) konnte es, sofern der Buchungstext größer 30 Zeichen war, zu einer Fehlermeldung kommen "Feld: <<Text >> Wert: Buchungstext xyz... / Der Feldinhalt ist länger als in diesem Feld zulässig.". Jetzt wird sichergestellt, dass nur 30 Zeichen in die Exportdatei übergeben werden.
Inventur erstellen / Inventur Bewertungsschema & Auswertung
Beim Erstellen der Inventur wurde bisher als letztes Einkaufsdatum die neuste Lagerbestandserhöhung in den Lagerbewegungen verwendet. Dies führte allerdings auch dazu, dass manuelle Lagerumbuchungen /-korrekturen, Auftragsstornos, sowie das letzte Inventurkorrekturdatum das "letzte Einkaufsdatum" sein konnten. Dies führte dazu, dass das Bewertungsschema zum Abwerten des Lagerbestand von falschen Werten ausging. Jetzt wird zum Ermitteln des letzten Einkaufsdatum nur noch der Wareneingang durchsucht und der neuste Wareneingang entspricht dem letzen Einkauf des Artikel. Eine verbesserte Abfragemethodik nach dem letzten Einkaufsdatum, lässt die Inventur nun 40x schneller Anlegen. Was früher 4min dauerte, ist nun in 6sek fertig.
Crossselling (Vorschlags-/ Folgeartikelfunktion) in Auftragsverwaltung
Wurde als Vorschlags-/ Folgeartikel ein Artikel mit Stückliste eingefügt, so kam die Fehlermeldung "Eigenschaft PMKS_VORGANGSART wurde nicht gefunden". Dieser Fehler wurde nun behoben.
Tools-Manager
Externer Start der Anwendung
Wurde der Tools-Manager nicht aus Goliath, sondern direkt aus dem Programmverzeichnis gestartet, so beendete sich die Anwendung nach dem Login. Es kann nun über das Benutzerrecht Allgemeine Rechte -> TAB Allgemein -> Externer Zugriff auf Tools Center festgelegt werden ob der User externen Zugriff hat oder nicht.
ZDE-Anwesenheitszeiterfassung
Bildschirmtastatur
Beim Klick auf den Button für die Windows-Bildschirmtastatur ist die Anwendung eingefroren. Jetzt wird die OSK.exe des Betriebssystems ordnungsgemäß aufgerufen.

Version 5.5.003.F vom 08.10.2018

Neuentwicklung

Goliath
Auftragsverwaltung -> Abbuchen
In dem Control wurde der Liefertermin als Spalte aufgenommen. Bei Stücklisten wird auch der Liefertermin des Stücklistensohn angezeigt.

Verbesserungen

Goliath
Windows-Benutzerkontensteuerung (UAC)
Goliath ist nun mit der höchsten Stufe der Windows-Benutzerkontensteuerung (UAC) kompatibel. Die UAC kann somit wieder aktiviert werden.
Angebote importieren
Die Artikelbezeichnung wird jetzt nicht mehr im UpperCase (Großbuchstaben) importiert. Es wird jetzt dasselbe Format wie in der Excelzelle verwendet.
Bei Dateipfaden mit Leerzeichen erscheint jetzt keine Fehlermeldung mehr.
RE-Status ändern
Beim Zurücksetzen einer Rechnung konnte es in seltenen Fällen dazu kommen, dass in der Auftragsverwaltung die Rechnung zurückgesetzt wurde, der OP allerdings bestehen blieb. Dieses Problem wurde mit der Meldung "Offener Posten für Rechnung xxxxxx konnte nicht gelöscht werden." von Goliath gemeldet. Dieselbe Meldung kam, wenn eine 0 Euro Rechnung (9999999999) zurückgesetzt wurde. Bei den 0 Euro Rechnungen wurde diese Meldung deaktiviert. Bei Rechnungen > 0 Euro wurde das Problem zwischen OP und Auftragsverwaltung behoben.
Datanorm-Import für den vorgelagerten Artikelstamm
Es wird jetzt geprüft ob die Importdatei auf Codepage OEM 850 konvertiert ist und dann in Codepage 1252 gewandelt, um Sonderzeichen wie ä,ö,ü korrekt darzustellen.
Generieren von PDF/A Dokumente
Reports mit farbigen OpenType-Schriftarten (*.otf) müssen nun nicht mehr manuell angepasst werden. Die PDF-Engine erkennt diese Felder nun und generiert die Textelemente korrekt.
XFRX Version 18.1.0 (Druck- und PDF-Engine)
Bessere PDF/A Compliance für PDF/A-1a und PDF/A-1b (ISO 19005-1:2005), sowie für PDF/A-3a (ISO 32000-1:2008).
Neuer Installer für die Installation des Update
Der Wise-Installater wurde durch InstallAware ersetzt. Somit wird der Installer nun auch als signierte Anwendung ausgeliefert.
Netzwerkweite Aktualisierung / Abgleich des Client mit der Datenbank
Es werden jetzt anstatt der früheren ~ 2500 Dateien nur noch ~ 200 Dateien abgeglichen.
Zusätzlich wird ein neues Verzeichnis für den Abgleich berücksichtigt, um user-defined Applications und Report-Images dauerhaft bereitstellen zu können. Das Verzeichnis liegt im Root der Datenbank als "PATCH_CUSTOM" (Bspw.: ..\vmksdata.50a\patch_custom). Um nun bspw. das Fußlogo der Reports dauerhaft verteilen zu können, muss der Client-Pfad in diesem Verzeichnis angelegt werden und die jeweilige(n) Datei(n) in diesem Verzeichnis abgelegt werden, bspw. so: ..\vmksdata.50a\patch_custom\tables\template\footer.png.
Zahlungs-Manager / DTA-Zuweisung
Bisher konnten DTA-Zuweisungen nur für getätigte Zahlungen der letzten 20 Tage zugewiesen werden. Der Abfragezeitraum wurde von 20 Tag auf 60 Tage erhöht. Zahlläufe, welche älter als 60 Tag sind müssen erneut exportiert werden, so dass diese wieder in den Abfragezeitraum rutschen.
Beenden von Goliath in Zusammenarbeit mit Outlook
Beim Beenden von Goliath konnte es zu einer Outlook-Meldung "Möchten Sie Ihre Änderungen speichern?" kommen. Dies passierte immer dann, wenn die letzte in Goliath erzeugte Mail nicht versendet, sondern verworfen wurde. Im Hintergrund hielt Goliath diese Mail noch offen. Jetzt wird diese Verbindung beim Beenden geschlossen.
Barverkauf mit vielen Spalten und Einträgen
Im Barverkauf konnte es bei einer Konfiguration mit sehr vielen eingeblendeten Spalten und zusätzlich vielen Zeilen bei einem Anzeigefilter von 0 dazu führen, dass es zu einer Fehlermeldung - Variable "A_TMP" wurde nicht gefunden - kommen konnte. Dieser Fehler wurde behoben.
OCR-Automatik
Dokumentengröße wurde verringert
Die Größe der PDF wurde auf 1/3 der bisherigen Größe reduziert

Fehlerkorrekturen

Goliath
Techniker-Modul -> Anfahrten definieren
Beim öffnen dieser Funktion konnte es zu einer Fehlermeldung "OLE-Fehlercode 0xBASCOMMANDBUTTON1" kommen.
Rechtsklick-Menü in Serviceverwaltung auf den Vertrag
Als Untermenüeintrag von "Abrechnung für Vertrag x drucken", wurde bei zusammengefassten Abrechnungen (Pauschale+Verbrauch) kein Text angezeigt, sofern der Abrechnungszeitraum zwischen Pauschale und Verbrauch unterschiedlich war. Jetzt wird bei diesen Abrechnungen der Text korrekt mit "Pauschale <Abrechnungzeitraum> + Verbrauch <Abrechnungszeitraum>" angezeigt.
Übergabe an Datev bei Gutschriften mit Skonto
Skontobeträge im Haben wurden nicht übergeben. Sprich wurde eine Debitoren- oder Kreditorengutschrift unter Skontoabzug gezahlt, so wurde der vermeintlich negative Skontobetrag nicht an Datev übergeben.
Angebote Importieren
Es konnte beim Aufruf der Maske zu einer Fehlermeldung "DRV_HEADER_DISCOUNT" kommen.
Es konnte beim Klick auf den Button zur Auswahl der Importdatei eine Fehlermeldung "Ungültiger Pfad oder Dateiname" geben, wenn der Pfad zur vorherigen Datei nicht mehr existierte. Ist der Pfad jetzt nicht mehr vorhanden, öffnet sich der Dateiauswahl-Dialog im Goliath-Client-Verzeichnis.
Default Zoom der Report-Preview wurde nicht beachtet
Wurde in den lokalen Einstellungen eine persönlicher Wert für den Default Zoom eingestellt, so wurde dieser nicht berücksichtigt.
Abbrechen des Druckvorgang in der Service-Verwaltung
Wurde der Druckvorgang in der Service-Verwaltung abgebrochen, so kam es zu einer Fehlermeldung "Variable LCDRDEFAPRINTER wurde nicht gefunden"
OP-Debitoren -> Beleg-Nr. überprüfen -> Button "Einstellungen"
Beim Klick auf dem Button kam es zu einer Fehlermeldung "Fehler beim Laden der Datei - Datensatz Nr. 522."
Auftragsverwaltung - Position hinzufügen/bearbeiten
Befand sich die zu bearbeitende Position im Rückstand und die Menge stand somit als negativer Wert im Feld Menge, wurde beim verlassen des Feld "Gesamt-Netto" mit der negativen Menge gerechnet. Dies führte bspw. dazu, dass ein Rabatt > 100 % errechnet wurde. Jetzt wird mit dem absoluten Wert der Menge gerechnet.
Artikel-Disposition (in Dispo-Variante 2) [Weinroter Kreis mit weißem Fragezeichen]
Beim Aufrufen der Artikel-Dispo konnte es zu einem Fehler mit der Meldung "Nummerischen Überlauf. Es sind Daten verloren gegangen." kommen, sofern bei einem oder mehreren Lägern (bspw. Rekla- oder Sperrlager) der Bestand auf "nicht verkaufsfähig" gesetzt wurde.
E-Mailversand
Beim generieren einer E-Mail über das Druckmenü konnte es zu einer Fehlermeldung "Element GETINSPECTOR kann nicht zu einem Objekt ausgewertet werden." kommen.
BestBuy
Abruf der Bilder und Produktdatenblätter via HTTPS
Der Abruf der Medien via HTTPS schlug fehl. Es wird jetzt HTTP und HTTPS unterstützt.
Abruf von COP/TradersGuide 2.0 konnte fehlschlagen
Korrektur eines nicht an den Anwender gemeldeten Fehler im Try/Catch.
Tools-Manager
Es wurden keine Einträge mehr angezeigt
Es konnte zum Verhalten kommen, dass im Tools-Manager keine Einträge mehr angezeigt werden.
OCR-Automatik
Probleme bei Scaneinstellungen > 200 dpi
Es konnte passieren, dass bei gescannten TIFF Dateien mit einer DPI > 200, jede Seite des PDF den Inhalt von Seite 1 der TIFF beinhaltet. Die OCR-Automatik wurde umgebaut, dass dieser Fehler nicht mehr passiert.

Version 5.5.002.A vom 14.06.2018

Neuentwicklungen

Goliath
Barverkauf
Im Barverkauf kann jetzt im Feld der Artikel-Nr. nicht nur inkremetell nach der Artikel-Nr. gesucht werden, sondern nach dem EAN-Code. Die Suche des EAN-Code ist nicht inkrementell, um die Vorschlagsliste nicht mit der Artikel-Nr. zu vermischen. EAN-Codes werden in der Regel immer gescannt, deshalb ist die Teilstringsuche nicht notwendig.
Konfigurieren der Anzahl an Druckkopien des Arbeitszeitnachweis für Mehrverbrauchsabrechnungen bei EDV-Verträgen
Es kann nun in den Globalen Einstellungen -> Serviceverträge-Einstellungen die Anzahl an Druckkopien festgelegt werden, ab welcher Kopie kein Arbeitszeitnachweis mehr ausgedruckt wird. (gilt nur für die Druckausgabe auf Drucker)
Wareneingang - Abweichender Kreditor für Rechnung
Es besteht nun im Wareneingangskopf nicht nur die Möglichkeit einen abweichenden Kreditor für die Rechnung einzutragen, sondern es werden jetzt auch alle steuerlichen Aspekte berücksichtigt. Dies bedeutet, dass die Möglichkeit besteht bei einem mehrwertsteuerpflichtigen Lieferanten einen abweichenden Kreditor zu hinterlegen, welcher nicht mehrwertsteuerpflichtig ist. Es wird nun dabei der korrekte Steuersatz verwendet, sowie das korrekte Gegenkonto für die Bildung des Buchungssatz. Ein klassischer Anwendungsfall ist eine Lieferung von Amazon, welche nach Ausstellung der Rechnung unerwartet keine MwSt. beinhaltet. Auch bei Warenlieferungen innerhalb von Deutschland, welche dem Reverse-Charge-Verfahren /Steuerschuldumkehrung (Tablet-PC, Prozessoren, Halbleiterplatten über 5000€) unterliegen, kann diese Funktion angewendet werden.
Angebotsimport aus Excel (ist jetzt für alle freigeschaltet, somit ohne Lizenzprüfung)
Im Angebotsimport aus Excel unter: Auftrags-Center -> Auftragsverwaltung -> Verfügbarer Funktionsbaum -> Angebote -> "Angebote importieren" kann nun auch der Rabatt % als Spalte importiert werden. Das Mapping enthält nun die Option "Rabatt %". Bei bestehenden Artikeln wird nun auch der Hersteller und das Gewicht aus dem Artikelstamm für die Angebotsposition verwendet.
Digitale Signatur der Software
Alle relevanten Anwendungen wie goliath.exe, mks_outlookscanner.exe, mks_azv_komplett.exe, reindex.exe, etc. besitzen nun eine digitale Signatur. Diese Signatur stellt den vertrauenswürdigen Herausgeber der Software sicher, was sich positiv auf die Zusammenarbeit mit den aktuellen Betriebssystemen, Virenscannern und dessen Sicherheitseinstellungen auswirkt.
Kompression der Anwendungen
Alle ausgelieferten Anwendungen des Goliath-Client sind nun stark komprimiert. Die Goliath.exe hatte bisher eine Größe von ~ 135MB, jetzt ist diese nur noch ~ 18MB. Diese Ersparnis macht sich besponders in großen Terminalserver-Installationen positiv bemerkbar.
DSGVO-Spezial - Generieren von PDF/A Dokumente
In den Globalen Einstellungen -> Druckeinstellungen -> PDF-Einstellungen, können nun alle existierenden PDF/A Formate als PDF/A Level gewählt werden. Diese Einstellung wirkt sich auf alle Dokumente bei der PDF-Generierung aus. Empfohlen wird PDF/A-3a. Hinweis: Durch das neue PDF/A Format erhöht sich die Dokumentengröße. Reports mit OpenType-Schriftarten (*.otf) müssen ggf. angepasst werden, sofern diese Schriftart farbig dargestellt wird. Die entsprechenden Felder müssen im Report-Editor auf "Undurchsichtig" gesetzt werden. TrueType-Schriftarten (*.ttf) sind hiervon nicht betroffen.
DSGVO-Spezial - Pfad zur Datenbank im Startscreen wurde entfernt
Um den Anwendern nicht direkt auf dem Startscreen den Pfad zur Datenbank anzuzeigen, wurde diese Information aus Sicherheitsgründen entfernt und nach Hilfe -> Info... verschoben.
DSGVO-Spezial - Abschluss eines Auftragsverarbeitungsvertrag beim Startup von Goliath
Nach der Anmeldung an Goliath erscheint die Möglichkeit einen AV-Vertrag mit der k-advice software GmbH abzuschließen.
Erleichterung zur netzwerkweiten Aktualisierung der Goliath.exe
Um eine neuere Goliath.exe an alle Clients zu verteilen, muss jetzt lediglich die neuere EXE nach "\\...\vmksdata.50a\patch\update\" kopiert werden. Der Client prüft nun bei jedem Neustart, ob in diesem Verzeichnis eine neuere Version der EXE liegt.

Verbesserungen

Goliath
Update-Setup
Die Setup zum Einspielen des Update prüft jetzt beim ausgewählten Datenbankverzeichnis, ob es sich wirklich um eine Goliath-Datenbank handelt.
Wird die "MKSDATA.DBC" nicht gefunden, so beendet die Setup den Installationsvorgang mit einer passenden Meldung.
Inventur - Zähllisten drucken
Wurden bei der Inventur die Zähllisten nach Warengruppen erzeugt und man wollte diese mit dem Filter "Nur Artikel mit Lageristbestand > 0" ausdrucken, so kam bei jeder Zählliste ohne Lagerbestand die Meldung "Keine Daten zum Drucken vorhanden". Die Meldung wurde jetzt abgeschaltet.
AV-Zeiterfassung
In der AV-Zeiterfassung im Auftrags-Center werden die inaktiven Benutzer der Combobox jetzt deaktiviert dargestellt und an das Ender der Combobox sortiert.
Service-Verwaltung - Kontostand für Vertrag
Manuelle Kontostandsbuchungen sind jetzt auch als Minus-Stunden möglich. Somit kann man bspw. den monatlichen Übertrag eines Stundenguthaben zum Ende der Abrechnungsperiode auf Null setzen.
Lastschriftmandat-Verwaltung
Bisher war es so, dass Lastschriftmandate bei keiner Verwendung in den letzten 36 Monate automatisch ihre Gültigkeit verloren. Mandate verlieren rechtlich nur nach Kündigung/Wiederspruch ihre Gültigkeit. Deshalb ist jetzt nur noch ausschlaggebend, dass das Mandat entweder noch nicht gültig ist, nicht mehr gültig ist oder gekündigt wurde. Der zeitliche Verfall wurde deaktiviert.
E-Mailversand
Bisher wurden aus Goliath generierte E-Mails bei einer bereits geöffneten Instanz von Outlook immer im Hintergrund geöffnet. Dies war sehr störend, weil jede Nachricht zum Versenden erst in den Vordergrund gerufen werden musste. Jetzt wird mittelst Win32API das E-Mail immer in den Vordergrund gerufen.
Service-Verwaltung - Funktion "Letzte Abrechnung für Vertrag n rückgänig machen"

Diese Funktion unterliegt jetzt dem Benutzerrecht "RE-Status ändern" aus der Auftragsverwaltung.

Auftragsverwaltung - Positionsauswahldialog bei Lieferschein drucken
Bisher wurden immer alle Lieferscheinpositionen per Standard zum Drucken angehakt, dabei war es egal ob eine einzelne Position bereits ein Druckdatum hatte oder nicht. Somit konnte es passieren, dass eine Lieferscheinposition versehentlich zwei Mal gedruckt und kommissioniert wurde. Jetzt werden per Standard nur noch die Positionen angehakt, welche noch nicht gedruckt wurden.
Startup der Anwendung
Manchmal passierte es, dass Goliath im Hintergrund einer anderen Anwendung gestartet ist. Jetzt wird sichergestellt, dass die Anwendung immer im Vordergrund ist, sowie der Focus im Feld der Passworteingabe steht. Man kann nun sofort das Kennwort eingeben, ohne vorher zur Maus greifen zu müssen.
Fernwartungstools
Der FastClient kann nun mit dem Hotkey F1 aus der gesamten Anwendung gestartet werden.
Der AnyDesk-Client kann nun mit dem Hotkey STRG+F1 aus der gesamten Anwendung gestartet werden.
Befüllen des Liefertermin bei EDV-Vertägen
Wird ein Valuta-Datum bei der EDV-Vertragsabrechnung in der Serviceverwaltung unter "Abrechnung EDV-Verträge" angegeben, so wird jetzt das Valuta-Datum in das Feld Liefertermin der LF- und RE-Position geschrieben. Bisher wurde immer das Tagesdatum verwendet. Bei den Click-Verträgen (Copy&More) bleibt zunächst das Tagesdatum.

Fehlerkorrekturen

Goliath
Neues Datev-Format - Kontenbeschriftungen
Bei einem regulären Wirtschaftsjahr mit Beginn Januar, konnte es bei einer Fibu-Übergabe für einen Zeitraum des Vorjahr dazu führen, dass Datev den Buchungstapel der Kontenbeschriftungen mit der Meldung "Falsches Wirtschaftsjahr" ablehnte. Grund dafür war, dass die Kontenbeschriftung zwar den korrekten Monat als Wirtschaftsjahr verwendete, jedoch als Jahr immer das Jahr des aktuellen Tag.
Jetzt orientiert sich das Wirtschaftsjahr im Buchungstapel der Kontenbeschriftungen, immer am ersten Tag der selektierten FiBu-Übergabe in der "FiBu-Übergabeliste".
Neues Datev-Format - Buchungsstapel bei abweichendem Wirtschaftsjahr
Bei einem abweichenden Wirtschaftsjahr wurde, sofern das aktuelle Kalenderjahr nicht mit dem Beginn des Wirtschaftsjahr übereinstimmte, der falsche Beginn des Wirtschaftsjahr übergeben. Jetzt wird ausgehend vom ersten Tag der gewählten FiBu-Übergabe der korrekte Beginn des Wirtschaftsjahr errechnet.
Neues Datev-Format - Buchungsstapel mit Fremdwährungen
Bislang wurde im neuen Buchungsstapelformat zwar der korrekte Währungskurs übergeben, allerdings missachtete Datev diesen Kurs, weil die Spalten "Basis-Umsatz" und "WKZ Basis-Umsatz" nicht befüllt waren. Jetzt werden die notwendigen Spalten befüllt und Datev rechnet bei der Stapelverarbeitung auch den korrekten Euro-Betrag.
Eintrag "Arbeitszeiten von Vertrag n bearbeiten"
Rechtsklick-Menü unter Service-Verwaltung -> Abrechnung EDV-Verträge war ohne Funktion.
Übersicht drucken in Nicht gedruckte XX-Positionen
Wollte man den Report über den Button "Übersicht drucken" in den Nicht gedruckten XX-Positionen unter Auftrags-Center -> Druck-Übersicht ausführen kam es zu einer Fehlermeldung. Fehler waren falsche Feldnamen im Druckcursor, welche nicht zu den Feldern im Report passten.
Inventur - Zähllisten-Import
Beim Zähllisten-Import aus Excel kam es zu einer Fehlermeldung, sofern doppelte Serien-Nr. in der Excel-Importdatei enthalten waren. Jetzt wird in die Excel-Importdatei die Zeilennummer der doppelten Serien-Nr. eingetragen, um dem Anwender einen geführte Fehlerliste bereitzustellen.
Gutschrift / Stornorechnung mit Seriennummern
Bislang wurden bei einer Gutschrift mit seriennummernpflichtigen Artikeln die Seriennummern immer auf das "Zentrallager" gebucht, selbst wenn für die Gutschriftsposition ein abweichendes Lager (bspw. Reklamationslager) ausgewählt wurde. Jetzt werden die Seriennummern korrekt in das Lager vereinnahmt, auf welchem auch der Bestand gebucht wird.
Benutzer-Rechte - Darf Rechnung/Gutschrift n Tage rückwirkend zurücksetzen
Wurde ein 4-stelliger Wert eingetragen so wurde Null in die Benutzer-Rechte eingetragen.
Service-Verwaltung - Vertragsabrechnung
Bei der Abrechnung der Verträge wurde das Merkmal "Logo in Report mit ausdrucken" nach der ersten Rechnung zurückgesetzt. Jetzt wird erst am Ende aller Rechnungen das Merkmal zurückgesetzt.
Fortschrittsanzeige / Thermometer
Im Artikelstamm -> Preisliste (intern) -> Preise Drucken -> Alle Artikel, konnte es zu einer Fehlermeldung "Invalid property value" kommen, wenn die Anzahl der Artikelpreise zu hoch war.
Entschlüsseln der Lizenzdatei
Beim Entschlüsseln der Lizenzdatei konnte es beim gleichzeitigen Start eine Aufgabenplanung dazu kommen, dass die temporären Dateien stehen geblieben sind und somit die nächsten Entschlüsselungen mit einem Fehler beendeten.
Löschen von Sachkonto im Kontenrahmen
Das Löschen eines Sachkonto führte immer zur Meldung "Wählen Sie ein Konto aus". Somit war das Löschen eines überflüssigen Konto nicht möglich.

Version 5.5.001.A vom 21.12.2017

Neuentwicklungen

Goliath
Neues Datev-Format (ab 01.01.2018)
Unterstützung des neuen Datev-Buchungsdatenformat (DATEVcsv EXTF...). Dieses Format wird von Datev als Ersatz zum Postversandformat (KNE-Format) gefordert. Der Import im Postversandformat ist somit ab Version Datev-Programme 11 und der darin enthaltenen Datev-Rechnungswesen V 6.0 Anwendung nicht mehr möglich.
Das neue Format ist in Goliath zu aktivieren unter: Einstellungen -> Globale Einstellungen -> OP-Einstellungen -> Fibu-Schnittstelle auf "Datev Format" setzen.
Wichtiger Hinweis:
Bitte pflegen Sie Ihre Mandanten- und Beraternummer bei der Fibu-Übergabe, sofern dies noch nicht passiert ist. Datev verweigert Ihnen ansonsten den Import der Buchungsstapel.
Zu pflegen an folgenden Stellen:
  • OP-Debitor -> Fibu-Übergabe -> FiBu-Export
  • Zahlungsmanager -> Fibu-Übergabe
  • Kassenbuch -> Fibu-Übergabe
Bei einem abweichenden Wirtschaftsjahr, hinterlegen Sie bitte den Beginn des Wirtschaftsjahr unter: Einstellungen -> Globale Einstellungen -> OP-Einstellungen -> "Beginn des Wirtschaftsjahres"
Sofern Sie im Datev die Unveränderbarkeit des übergebenen Buchungsstapel sicherstellen möchten (GoBD), können Sie in der Datei das Merkmal, den Buchungsstapel beim Import in Datev festzuschreiben, in Goliath einstellen. Dieses Merkmal wird an folgender Stelle gesetzt: Einstellungen -> Globale Einstellungen -> OP-Einstellungen -> "DATEV Stapel festschreiben". Per Standard wird der Stapel nicht festgeschrieben.
Dokumentenzuordnung per Drag'n'Drop
Es existiert nun in Goliath an allen notwendigen Stellen die Möglichkeit externe Dokumente bspw. vom Desktop, Dateiordner und Outlook in Goliath zuordnen zu können. Ein Umsetzung für den E-Mail Client david der Firma Tobit.Software ist nicht vorgesehen.
Das detaillierte How-to finden Sie hier: Dokumentenzuordnung per Drag'n'Drop
Automatischer Arbeitszeitnachweis für Mehrverbrauchsabrechnungen bei EDV-Verträgen (lizenzpflichtig)
Es kann nun auf Vertragsebene festgelegt werden, ob bei einer Mehrverbrauchsabrechnung der Arbeitszeitnachweis automatisiert der Rechnung beigefügt wird. Für das Druckziel -Drucker-, wird der Arbeitszeitnachweis an denselben Drucker gesendet wie auch die Rechnung. Bei Auswahl des Druckziel -E-Mail-, wird der Arbeitszeitnachweis als zusätzliches Attachment der E-Mail beigefügt.
Das detaillierte How-to finden Sie hier: Automatischer Arbeitszeitnachweis für Mehrverbrauchsabrechnungen
Funktion Alle-Abbuchungen/-Wandelungen rückgängig machen
Im Rightklick-Menü der Auftragspositionen sind nun zwei neue Einträge vorhanden, welche eine Rückbuchung und Rückwandelung der Auftragspositionen durchführt. Auftragspositionen, welche bereits als Rechnung gedruckt oder in eine Sammelrechnung aufgenommen wurden sind von dieser Funktion ausgenommen. Um eine Auftragsposition aus einer Sammelrechnung zurückzuholen, muss die gesamte Sammelrechnung gelöscht werden.
Rechnungsstatus ändern mit zeitlicher Beschränkung
Als Benutzerrecht kann nun festgelegt werden, wie viele Tage rückwirkend ein Benutzer eine Rechnung zurücksetzen darf. Somit könnte man bspw. steuern, dass ein Benutzer lediglich die heute erstellten Rechnungen zurücksetzen darf. Diese Einstellung wird gesetzt unter: Einstellungen -> Benutzer-Rechte -> Benutzer auswählen -> Allgemeine Rechte -> Finanzen -> "Darf Rechnung/Gutschrift XXXX Tage rückwirkend zurücksetzen (ausgenommen sind 9999999999 Belege)"
Angebotsimport aus Excel
Im Angebotsimport aus Excel unter: Auftrags-Center -> Auftragsverwaltung -> Verfügbarer Funktionsbaum -> Angebote -> "Angebote importieren" kann nun auch zwischen Einstands- und Verkaufspreis unterschieden werden. Das Mapping enthält nun die Option "Einstands-Preis und Preis-Netto"
Artikel kopieren
Im Auswahldialog zum Artikel kopieren kann nun zusätzlich die Option angehakt werden "Artikel-Benutzerfelder kopieren"
Zwischenablage beim öffnen von Kunden-/Lieferanten-/Interessentendokumenten
Bisher war es eine Standardfunktion, dass beim öffnen eines Dokument die Firmenadresse in die Zwischenablage kopiert wurde. Diese Funktion kann hilfreich, manchmal aber auch nur nervig sein. Deshalb wurde eine clientseitige Einstellung geschaffen: "Einstellungen -> Lokale Einstellungen -> Dokumenten-Einstellungen -> "Adresse beim Öffnen des Dokuments in die Zwischenablage"
Auftragsrückstände - Abbuchen von gesperrten Aufträgen
In den Auftragsrückständen unter Auftrags-Center -> Auftragsverwaltung -> Verfügbarer Funktionsbaum -> Aufträge -> "Auftragsrückstände" werden gesperrte Aufträge jetzt rot markiert angezeigt und das Abbuchen der Auftragspositionen wird gesperrt
Meldung bei Stückliste-Bearbeiten in der Auftragsverwaltung ist nun editierbar
Wurde ein Stücklistenartikel in der Auftragsverwaltung bearbeitet, erhielt der User die Frage ob der Preis- und Zusatztext des Vaterartikel (Auftragsposition) aktualisiert werden soll. Dies konnte unter Umständen hilfreich, allerdings auch zur Verfälschung bewusst kalkulierter Preise oder konfigurierter Texte führen. Die Aktualisierung und Frage kann nun deaktiviert werden unter: Einstellungen -> Globale Einstellungen -> Auftragsverwaltungseinstellungen -> Weitere Parameter -> "deaktivieren der Funktion (Preise und Zusatztext bei Stücklisten aktualisieren)
User-Helpdesk - Fernwartungsclient

Der Helpdesk enthält jetzt den Client des Fastviewer und AnyDesk zur schnelleren Supportunterstützung per Fernwartung des Anwender. Toolbar -> HelpDesk -> k-advice FastViewer/AnyDesk

Verbesserungen

Goliath
E-Mailrechnung
Sofern ein Kunde auf E-Mailrechnung stand, kam bisher bei jedem Druckziel des Druckdialog die Frage, ob die Rechnung wirklich auf dem Drucker gedruckt werden soll.
Jetzt kommt die Abfrage nur noch beim Druckziel "Drucken auf Drucker"
Nicht gedruckte RE-Positionen
Im Modul Nicht gedruckte RE-Positionen wird jetzt das "Logo in Report mit ausdrucken" - Merkmal wieder auf False zurückgesetzt. Früher blieb es auf True stehen und führte somit ggf. zu einem unerwünschten Ausdruck mit Logo.
Rückstände überprüfen bei Techniker-Aufträgen
In der Auftragsverwaltung konnte es bisher passieren, dass Positionen aus dem Techniker-Modul über die Funktion "Rückstände überprüfen" gesplittet wurden und somit bei der gesplitteten Menge die Referenz auf die Techniker-Auftragsposition verloren ging. Der Button "Rückstände überprüfen" ist nun bei Projekten mit referenzierendem Techniker-Auftrag gesperrt.
Berechnung des Beleg-Endbetrag in Kombination mit einem Kopf-/Projektrabatt.
Wurde bisher in einem Auftrag ein Kopfrabatt eingetragen und die Funktion des Auswahldialog für AB-Positionen war aktiv (Einstellungen -> Globale Einstellungen -> Auftragsverwaltungseinstellungen -> Weitere Parameter -> "Positions-Auswahldialog für AB Drucken", wurde der Kopfrabatt nur abgezogen wenn alle AB-Positionen zum Drucken angehakt waren. Jetzt wird der Kopfrabatt je Position anteilig berechnet und an das Formular übergeben.
Inventur-Zähllistenimport aus Excel mit Nachkommastellen
Der Zähllistenimport aus Excel wurde erweitert, um auch Produkte kleiner der Menge 1, sowie Produkte mit Nachkommastellen importieren zu können. Bisher wurde immer auf eine ganze Zahl gerundet. Artikel mit Seriennummern können weiterhin nur als ganzzahlige Menge importiert werden.
BDE-Zeiterfassung
Die Anwendung zur Betriebsdatenerfassung für produzierende Unternehmen wurde optimiert, um die Netzwerklast der Anwendung auf ein Minimum zu reduzieren.
Maskendesign Techniker-Modul
Der Button "Position hinzufügen/bearbeiten/löschen" wurde besser positioniert
Die Optionen "Zusatztextanzeige und die Checkboxen - Zweifarbige Anzeige, Vertikale Linie, Horizontale Linie" passten sich nicht am Resize/Splitter des Techniker-Center an und konnten somit hinter dem Grid verschwinden
E-Mail zuordnen in Technikerauftragskopf
Wird die Funktion "Email zuordnen" im Technikerauftragskopf genutzt wird jetzt nur noch das Mail, aber nicht mehr der gesamte Body der Mail in das Feld "Notiz" des Technikerauftragskopf übernommen.
Doppelbelegung des Shortcut im Wareneingang
Wurde im Wareneingang eine Teilmenge eingebucht und somit gefragt ob die restliche Menge erledigt gesetzt werden soll, war eine Doppelbelegung der Buttons "Ja für Alle" und "Abbrechen"
Masekdesign Bankverbindung bearbeiten
Die IBAN wird jetzt im korrekten Format XXXX XXXX XXXX .... angezeigt. Einstellungen -> Allgemeine Daten -> "OP-Bankkonten"
Suchgeschwindigkeit nach Kunden
Die Suchgeschwindigkeit für Kunden/Lieferanten/Interessenten wurde für Datenbanken mit einer Userzahl > 30 User erheblich optimiert. Vorher konnte es zu einer Wartezeit von > 5 Sekunden kommen.
Aufräumen des Rightklick-Menü der Auftragsverwaltung
Das Rightklick-Menü der Auftragsverwaltung wurde konsolidiert. Überflüssige Einträge wurden entfernt, um das Menü übersichtlicher zu gestalten.
Funktionsmanager
Beim Versenden eines E-Mail Template wurde die Frage "Möchten Sie die Änderungen speichern?" abgeschaltet und im Hintergrund automatisiert.
Installations-Setup für das Update wurde erneuert
Der Installer für das Update wurde komplett erneuert, um dem Administrator eine geführte Installation á la Best-Practice bereitzustellen. Fehler werden dabei minimiert und der Installationsprozess vereinfacht.

Fehlerkorrekturen

Goliath
Berechnung der Umsatzsteuer von Angebot bis Rechnung - Rundungsfehler
Bei der Berechnung des Umsatzsteuerbetrag in der Auftragsverwaltung konnte es zu einem Rundungsfehler kommen.
Beispiel: Bei einem Nettowert von 97,50 € wurde ein USt.-Betrag von 18,52 € errechnet. Jetzt wird korrekt auf 18,53 € gerundet.
Inventur-Zähllistenimport aus Excel > Version Excel 2010 - beheben eines Kompatibilitätsproblem
Ab Excel-Version 2013 wurde in der Sytax von Visual Basic for Application (VBA) das Speichern der Exceldatei selbst verändert. Dies führte dazu, dass beim Import der Zählliste aus Excel, Goliath mit einer Fehlermeldung den Import nicht abschließen konnte und die Fehlerliste somit nicht in die Importdatei zurückgeschrieben werden konnte. Es wird jetzt geprüft aus welcher Excel-Version importiert wird und somit die jeweilige Syntax verwendet.
Druckroutine mit Meldung auf der Goliath-Maske
Bei einem Druckjob mit mehreren Vorgängen bspw. aus der Service-Verwaltung - Vertragsabrechnung oder Auftrags-Center -> Druckübersicht -> Nicht gedruckte RE-Positionen, konnte es dazu kommen, dass sich die gesamte Maske durch eine Meldung (TALK-Window) "bru_gesamt" oder "CNT()" nach unten verschoben.
Druckziel in Techniker-Center setzte sich nicht zurück
Wurde im Techniker-Center ein Auftrag über die Funktion Rightklick auf Technikerauftrag -> "Auftrag XXXXX abrechnen und Rechnung+Lieferschein drucken" abgerechnet, so setzte Goliath das Druckziel (bspw. Bildschirm) nicht mehr zurück und alle folgenden Rechnungen kamen am initial ausgewählten Druckziel raus. Nur über einen Neustart von Goliath konnte das Problem bisher behoben werden.
Fehlermeldung -Variable "Anzeige" wurde nicht gefunden
Sofern in der Übersicht der "Nicht gedruckte RE-Positionen" unter Auftrags-Center -> Druck-Übersicht keine Vorgänge vorhanden waren kam es zu einer Fehlermeldung.
Rückstände überprüfen in der Auftragsverwaltung in der Goliath-Production
Wurde in der Version Goliath-Production der Button "Rückstände überprüfen" ausgeführt und die Auftragsposition wurde gesplittet, sind die Produktionsstücklisten inkl. der Arbeitspläne für die neue Auftragsposition nicht übernommen worden.
Druckschacht-Information ging beim Drucken verloren
Es konnte unter bestimmten Umständen dazu führen, dass bei einem Stapel-Rechnungsdruck, bspw. Service-Verwaltung - Vertragsabrechnung der individuell gewählte Druckschacht verloren ging.
Kassenbuch mit vielen Spalten und Einträgen
Im Kassenbuch konnte es bei einer Konfiguration mit sehr vielen eingeblendeten Spalten und zusätzlich vielen Zeilen bei einem Anzeigefilter von 0 dazu führen, dass es zu einer Fehlermeldung - Variable "A_TMP" wurde nicht gefunden - kommen konnte.
Startverhalten von Goliath
Beim Starten von Goliath konnte es zur Fehlermeldung "Schwerer Fehler beim Starten von Goliath in mks_fix_bestbuy" kommen. Fehler wurde behoben.